viernes, 19 de febrero de 2010

ECW files, the shp--tiff--ecw tantra

Maybe this will work for you:
1) Got a new version of gvSIG 1.9
2) Open a new project
3) Load a shape file
4) Load a tiff one
5) Now and only now, load any ecw
OPTION B
1) Alternatively download GDAL 1.7 and its ecw plugin from www.kyngchaos.com
2) Install both of them
3) Open a terminal and type
4) sudo rm -r /Applications/gvSIG1_9b12.app/Contents/Frameworks
5) sudo ln -s /Library/Frameworks/GDAL.framework /Applications/gvSIG1_9b12.app/Contents/Frameworks/GDAL.framework
6) Enjoy but not forget the tantra shp--tiff--ecw
****BE AWARE THAT gvSIG1_9b12.app SHOULD BE the name of your application****

As soon as I got confirmation from anybody of this tantra working I will upload the new version with sextante and navtable.

5 comentarios:

Alvaro dijo...

Tengo un MAC, OX Tiger, e instalado la vesrión 1.9 propuesta, y al iniciarla se me cuelga cuando inicia la configuración de extensiones.

me podrian sugerir algo al respecto?

saludos cordiales

Agustin dijo...

Con tiger no te va ir, el problema, creo, es que algunas cosas tiran del java 1.6 y para eso en mac se necesita el snow leopard. Gracias por compartir tu experiencia. Creo que la versión anterior si va, o incluos la de Ai2.

gene dijo...

Pues si, por el momento funciona basicamente en mi Mac Tiger pero no hice todavía no hice todas las pruebas...

gene dijo...

y sextante crea un error fatal

Agustin dijo...

sextant está compilado con java 1.6, creo, y por eso tira ese error, lo puedes quitar. Botón derecho mostar contenido del paquete o desde el terminal
rm -rf /Applications/gvSIG19v1.app/Contents/Resources/Java/gvSIG/extensiones/es.unex.sextnate*